re = /^(?>(?P<scheme>[^:\/?#]+):(?=\/\/))?(?>\/\/)?(?>(?>(?P<login>[^:]+)(?::(?P<password>[^@]+)?)?@)?(?P<host>[^@\/?#:]*)(?::(?P<port>\d+)?)?)?(?P<path>[^?#]*)(?>\?(?P<query>[^#]*))?(?>#(?P<fragment>.*))?/m
str = 'https://ftpuserftp.trong.live:ftp.trong.live@ftp.trong.live:443/prv/test.jpg'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end