using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[1-9]+\d*[.,]\d{2}(?!0)";
string input = @"12.34
12.340 //BAD - Zero cannot be the first character
12.345 //OK - I want 5 to be discarded
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}