import re
regex = re.compile(r"[1-9]+\d*[.,]\d{2}(?!0)", flags=re.MULTILINE)
test_str = ("12.34\n"
"12.340 //BAD - Zero cannot be the first character\n"
"12.345 //OK - I want 5 to be discarded\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")