re = /[1-9]+\d*[.,]\d{2}(?!0)/m
str = '12.34
12.340 //BAD - Zero cannot be the first character
12.345 //OK - I want 5 to be discarded
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end