package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^Last dying gasp time\h*:\h*(?:-|\d{4}(?:-\d{2}){2}\h+\d{2}(?::\d{2}){2})$`)
var str = `Last dying gasp time : -
Last dying gasp time : 2021-08-13 18:27:44`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}