// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^Last dying gasp time\h*:\h*(?:-|\d{4}(?:-\d{2}){2}\h+\d{2}(?::\d{2}){2})$").unwrap();
let string = "Last dying gasp time : -
Last dying gasp time : 2021-08-13 18:27:44";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}