re = /^Last dying gasp time\h*:\h*(?:-|\d{4}(?:-\d{2}){2}\h+\d{2}(?::\d{2}){2})$/m
str = 'Last dying gasp time : -
Last dying gasp time : 2021-08-13 18:27:44'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end