import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^Last dying gasp time\\h*:\\h*(?:-|\\d{4}(?:-\\d{2}){2}\\h+\\d{2}(?::\\d{2}){2})$";
final String string = "Last dying gasp time : -\n\n"
+ "Last dying gasp time : 2021-08-13 18:27:44";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}