import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\btypeof window(?![\\w.$])";
final String string = "typeof window === 'undefined'\n"
+ "typeof window.x === 'undefined'\n"
+ "typeof window1 === 'undefined'\n"
+ "typeof windowx === 'undefined'\n"
+ "typeof windowX === 'undefined'\n"
+ "typeof window_ === 'undefined'\n"
+ "typeof window$ === 'undefined'\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}