const regex = /\btypeof window(?![\w.$])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\btypeof window(?![\\w.$])', 'gm')
const str = `typeof window === 'undefined'
typeof window.x === 'undefined'
typeof window1 === 'undefined'
typeof windowx === 'undefined'
typeof windowX === 'undefined'
typeof window_ === 'undefined'
typeof window\$ === 'undefined'
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}