import re
regex = re.compile(r"\btypeof window(?![\w.$])", flags=re.MULTILINE)
test_str = ("typeof window === 'undefined'\n"
"typeof window.x === 'undefined'\n"
"typeof window1 === 'undefined'\n"
"typeof windowx === 'undefined'\n"
"typeof windowX === 'undefined'\n"
"typeof window_ === 'undefined'\n"
"typeof window$ === 'undefined'\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")