import Foundation
let pattern = #"\btypeof window(?![\w.$])"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
typeof window === 'undefined'
typeof window.x === 'undefined'
typeof window1 === 'undefined'
typeof windowx === 'undefined'
typeof windowX === 'undefined'
typeof window_ === 'undefined'
typeof window$ === 'undefined'
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)