#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((?<emoji_left>(?::\w*:|\ud83c[\udf00-\udfff]|\ud83d[\udc00-\ude4f\ude80-\udeff]|[\u2600-\u2B55]))\s)?(?<type>\w+)(?:\((?<scope>[^)]*)\))?!?:\s((?<emoji_center>(?::\w*:|\ud83c[\udf00-\udfff]|\ud83d[\udc00-\ude4f\ude80-\udeff]|[\u2600-\u2B55]))\s)?(?<subject>(?:(?!#).)*(?:(?!\s).))(?:\s(?<ticket>#(?<ticket_number>\w+)|\(#(?<ticket_number>\w+)\)))?(?:\s(?<emoji_right>(?::\w*:|\ud83c[\udf00-\udfff]|\ud83d[\udc00-\ude4f\ude80-\udeff]|[\u2600-\u2B55])))?$"
Local $sString = "chore(scope): test" & @CRLF & _
"" & @CRLF & _
"chore(scope)!: test" & @CRLF & _
"" & @CRLF & _
"chore!: test" & @CRLF & _
"" & @CRLF & _
"chore!(scope)!: test" & @CRLF & _
"" & @CRLF & _
"hello: :test: test #111 ✨" & @CRLF & _
"" & @CRLF & _
":start: test: 1wsdwqs #11111" & @CRLF & _
"" & @CRLF & _
"✨ feat(unicode): ✨ adasas sfsd :das: #1d1w ✨" & @CRLF & _
"" & @CRLF & _
"feat(unicode): add unicode suppdadass o # (#rtasa) ✨" & @CRLF & _
"" & @CRLF & _
":hello: test: test" & @CRLF & _
"" & @CRLF & _
":start: chore(scope): test" & @CRLF & _
"" & @CRLF & _
":start: chore(scope): test #123" & @CRLF & _
"" & @CRLF & _
":memo: docs: update README.md" & @CRLF & _
"" & @CRLF & _
":start: chore(scope): i have a word #123" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
":package: feat(parser-opts): extract parser-opts packages" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
":sparkles: feat(changelog): 添加中文标题" & @CRLF & _
"" & @CRLF & _
":sparkles: feat(changelog): add chinese title" & @CRLF & _
"" & @CRLF & _
"✨ feat(unicode): add unicode support" & @CRLF & _
"" & @CRLF & _
"😌 test(only): add unicode support" & @CRLF & _
"" & @CRLF & _
":sparkles: feat: hello world (#100)" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")