# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^((?<emoji_left>(?::\w*:|\ud83c[\udf00-\udfff]|\ud83d[\udc00-\ude4f\ude80-\udeff]|[\u2600-\u2B55]))\s)?(?<type>\w+)(?:\((?<scope>[^)]*)\))?!?:\s((?<emoji_center>(?::\w*:|\ud83c[\udf00-\udfff]|\ud83d[\udc00-\ude4f\ude80-\udeff]|[\u2600-\u2B55]))\s)?(?<subject>(?:(?!#).)*(?:(?!\s).))(?:\s(?<ticket>#(?<ticket_number>\w+)|\(#(?<ticket_number>\w+)\)))?(?:\s(?<emoji_right>(?::\w*:|\ud83c[\udf00-\udfff]|\ud83d[\udc00-\ude4f\ude80-\udeff]|[\u2600-\u2B55])))?$"
test_str = ("chore(scope): test\n\n"
"chore(scope)!: test\n\n"
"chore!: test\n\n"
"chore!(scope)!: test\n\n"
"hello: :test: test #111 ✨\n\n"
":start: test: 1wsdwqs #11111\n\n"
"✨ feat(unicode): ✨ adasas sfsd :das: #1d1w ✨\n\n"
"feat(unicode): add unicode suppdadass o # (#rtasa) ✨\n\n"
":hello: test: test\n\n"
":start: chore(scope): test\n\n"
":start: chore(scope): test #123\n\n"
":memo: docs: update README.md\n\n"
":start: chore(scope): i have a word #123\n\n\n"
":package: feat(parser-opts): extract parser-opts packages\n\n\n"
":sparkles: feat(changelog): 添加中文标题\n\n"
":sparkles: feat(changelog): add chinese title\n\n"
"✨ feat(unicode): add unicode support\n\n"
"😌 test(only): add unicode support\n\n"
":sparkles: feat: hello world (#100)\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.