package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[\]()\[]+`)
var str = `this is a blabla (32332) [XAML]`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}