import re
regex = re.compile(r"[\]()\[]+", flags=re.MULTILINE)
test_str = "this is a blabla (32332) [XAML]"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)