$re = '/[\]()\[]+/m';
$str = 'this is a blabla (32332) [XAML]';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;