re = /(?:\\x[A-Fa-f0-9]{2})+/
str = 'Ya bani taplak dkk \\xf0\\x9f\\x98\\x84\\xf0\\x9f\\x98\\x84\\xf0\\x9f\\x98\\x84
Setidaknya gw punya jari tengah buat lu, sebelom gw ukur nyali sama bacot lu \\xf0\\x9f\\x98\\x8f
Ari sarua beki mah repeh monyet\\xf0\\x9f\\x98\\x86\\xf0\\x9f\\x98\\x86
Cerita silat lae \\xf0\\x9f\\x98\\x80 semacam Kho Ping Hoo yang dari Indonesia, tapi Liang Ie Shen penulis dari China'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result