re = /(25|26|27|28|29)\/11\/1995/m
str = 'String dates[] = {"25/11/1995", "26/11/1995", "27/11/1995", "28/11/1995","29/11/1995"};'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end