// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(25|26|27|28|29)\/11\/1995").unwrap();
let string = "String dates[] = {\"25/11/1995\", \"26/11/1995\", \"27/11/1995\", \"28/11/1995\",\"29/11/1995\"};";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}