#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\d+(?:\.\d+)+\b(.*)((?:\n(?!\d+\.\d).*)*)"
Local $sString = "1.1 Introduction" & @CRLF & _
"There are some sentences in here that I want and I want to do other things with them. There could be hundreds of sentences, who cares." & @CRLF & _
"1.1.1 Something Else" & @CRLF & _
"This is where we talk about something else in life." & @CRLF & _
"..." & @CRLF & _
"5.1.1 Conclusion"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")