using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @" *\| *(?:CoordAddon|ЯндексКарта)[^\|\}]+\n";
string input = @"{{Персона
|имя при рождении = Вася
|CoordAddon
= Василий Иваныч |дата рождения = 1990
}}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}