re = / *\| *(?:CoordAddon|ЯндексКарта)[^\|\}]+\n/m
str = '{{Персона
|имя при рождении = Вася
|CoordAddon
= Василий Иваныч |дата рождения = 1990
}}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end