$re = '/ *\| *(?:CoordAddon|ЯндексКарта)[^\|\}]+\n/m';
$str = '{{Персона
|имя при рождении = Вася
|CoordAddon
= Василий Иваныч |дата рождения = 1990
}}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);