package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m) *\| *(?:CoordAddon|ЯндексКарта)[^\|\}]+\n`)
var str = `{{Персона
|имя при рождении = Вася
|CoordAddon
= Василий Иваныч |дата рождения = 1990
}}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}