import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(h[1,3,5]-)?epns(?(1)broker0[1-7])\\.eset\\.com$";
final String string = "epns.eset.com\n\n"
+ "h1-epnsbroker01.eset.com\n"
+ "h1-epnsbroker02.eset.com\n"
+ "h1-epnsbroker03.eset.com\n"
+ "h1-epnsbroker04.eset.com\n"
+ "h1-epnsbroker05.eset.com\n"
+ "h1-epnsbroker06.eset.com\n"
+ "h1-epnsbroker07.eset.com\n\n"
+ "h3-epnsbroker01.eset.com\n"
+ "h3-epnsbroker02.eset.com\n"
+ "h3-epnsbroker03.eset.com\n"
+ "h3-epnsbroker04.eset.com\n"
+ "h3-epnsbroker05.eset.com\n"
+ "h3-epnsbroker06.eset.com\n"
+ "h3-epnsbroker07.eset.com\n\n"
+ "h5-epnsbroker01.eset.com\n"
+ "h5-epnsbroker02.eset.com\n"
+ "h5-epnsbroker03.eset.com\n"
+ "h5-epnsbroker04.eset.com\n"
+ "h5-epnsbroker05.eset.com\n"
+ "h5-epnsbroker06.eset.com\n"
+ "h5-epnsbroker07.eset.com";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}