import re
regex = re.compile(r"^(h[1,3,5]-)?epns(?(1)broker0[1-7])\.eset\.com$", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("epns.eset.com\n\n"
"h1-epnsbroker01.eset.com\n"
"h1-epnsbroker02.eset.com\n"
"h1-epnsbroker03.eset.com\n"
"h1-epnsbroker04.eset.com\n"
"h1-epnsbroker05.eset.com\n"
"h1-epnsbroker06.eset.com\n"
"h1-epnsbroker07.eset.com\n\n"
"h3-epnsbroker01.eset.com\n"
"h3-epnsbroker02.eset.com\n"
"h3-epnsbroker03.eset.com\n"
"h3-epnsbroker04.eset.com\n"
"h3-epnsbroker05.eset.com\n"
"h3-epnsbroker06.eset.com\n"
"h3-epnsbroker07.eset.com\n\n"
"h5-epnsbroker01.eset.com\n"
"h5-epnsbroker02.eset.com\n"
"h5-epnsbroker03.eset.com\n"
"h5-epnsbroker04.eset.com\n"
"h5-epnsbroker05.eset.com\n"
"h5-epnsbroker06.eset.com\n"
"h5-epnsbroker07.eset.com")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")