import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "-?[a-z_]\\w*(?:=\".*?\"(?=\\h+(?:-[a-z](?=\\h|$)|[a-z]\\w*=)|$)|\\S+)?";
final String string = "-a var1=Bat\"m/an -b var2=\" -a=\"lol \" -c var3=\" M^a%g-i=c \"\n\n"
+ "var=\" \" hi \" \"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}