$re = '/-?[a-z_]\w*(?:=".*?"(?=\h+(?:-[a-z](?=\h|$)|[a-z]\w*=)|$)|\S+)?/m';
$str = '-a var1=Bat"m/an -b var2=" -a="lol " -c var3=" M^a%g-i=c "
var=" " hi " "';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);