const regex = /-?[a-z_]\w*(?:=".*?"(?=\h+(?:-[a-z](?=\h|$)|[a-z]\w*=)|$)|\S+)?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('-?[a-z_]\\w*(?:=".*?"(?=\\h+(?:-[a-z](?=\\h|$)|[a-z]\\w*=)|$)|\\S+)?', 'gm')
const str = `-a var1=Bat"m/an -b var2=" -a="lol " -c var3=" M^a%g-i=c "
var=" " hi " "`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}