re = /-?[a-z_]\w*(?:=".*?"(?=\h+(?:-[a-z](?=\h|$)|[a-z]\w*=)|$)|\S+)?/m
str = '-a var1=Bat"m/an -b var2=" -a="lol " -c var3=" M^a%g-i=c "
var=" " hi " "'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end