using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^<.+=""(.+)""><\/.+>$";
string input = @"<h1>hello/h1>
<script src=""http://www.test.com/file1.js""></script>
<script src=""http://www.test.com/file2.js""></script>
<a href=""http://www.test.com/file3""></a>
<a href=""http://www.test.com/file4""></a>
<p>bye</p>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}