$re = '/^<.+="(.+)"><\/.+>$/m';
$str = '<h1>hello/h1>
<script src="http://www.test.com/file1.js"></script>
<script src="http://www.test.com/file2.js"></script>
<a href="http://www.test.com/file3"></a>
<a href="http://www.test.com/file4"></a>
<p>bye</p>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);