package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^<.+="(.+)"><\/.+>$`)
var str = `<h1>hello/h1>
<script src="http://www.test.com/file1.js"></script>
<script src="http://www.test.com/file2.js"></script>
<a href="http://www.test.com/file3"></a>
<a href="http://www.test.com/file4"></a>
<p>bye</p>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}