// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)^<.+="(.+)"><\/.+>$"#).unwrap();
let string = "<h1>hello/h1>
<script src=\"http://www.test.com/file1.js\"></script>
<script src=\"http://www.test.com/file2.js\"></script>
<a href=\"http://www.test.com/file3\"></a>
<a href=\"http://www.test.com/file4\"></a>
<p>bye</p>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}