package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([^:]+)`)
var str = `52152525121512@gmail.com:161361361:1251136136
532353472626326@gmail.com:2361251251225:-
126125252155@gmail.com:215125151251252:135263623,13631535315`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}