import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([^:]+)";
final String string = "52152525121512@gmail.com:161361361:1251136136\n"
+ "532353472626326@gmail.com:2361251251225:-\n"
+ "126125252155@gmail.com:215125151251252:135263623,13631535315";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}