// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([^:]+)").unwrap();
let string = "52152525121512@gmail.com:161361361:1251136136
532353472626326@gmail.com:2361251251225:-
126125252155@gmail.com:215125151251252:135263623,13631535315";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}