using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[U][S]\s(?:\d{1}\,\d{3}\,\d{3})";
string input = @"Application/Control Number: (US 5,092,007)";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}