package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[U][S]\s(?:\d{1}\,\d{3}\,\d{3})`)
var str = `Application/Control Number: (US 5,092,007)`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}