re = /[U][S]\s(?:\d{1}\,\d{3}\,\d{3})/
str = 'Application/Control Number: (US 5,092,007)'
# Print the match result
str.match(re) do |match|
puts match.to_s
end