#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!.*\b(two|three|five)\b.*\b(?!\1)(two|three|five)\b.*\b(?!\1|\2)(two|three|five)\b).*"
Local $sString = "one two three four five" & @CRLF & _
"one two three five" & @CRLF & _
"one two five" & @CRLF & _
"one three five" & @CRLF & _
"four five" & @CRLF & _
"one two four three five"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")