using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!.*\b(two|three|five)\b.*\b(?!\1)(two|three|five)\b.*\b(?!\1|\2)(two|three|five)\b).*";
string input = @"one two three four five
one two three five
one two five
one three five
four five
one two four three five";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}