$re = '/^(?!.*\b(two|three|five)\b.*\b(?!\1)(two|three|five)\b.*\b(?!\1|\2)(two|three|five)\b).*/m';
$str = 'one two three four five
one two three five
one two five
one three five
four five
one two four three five';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);