re = /^(?!.*\b(two|three|five)\b.*\b(?!\1)(two|three|five)\b.*\b(?!\1|\2)(two|three|five)\b).*/m
str = 'one two three four five
one two three five
one two five
one three five
four five
one two four three five'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end