import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([^\\s]*\\s*)\\\\rem\\{(?:lp|db)\\}(\\{((?>[^\\{\\}]|\\n|(?2))*)\\})(\\s?[^\\s]*)";
final String string = "\n"
+ "Some text etc word\\rem{lp}{ more text {\\ce{O2}} further text {\\ce{H2O}} . some other text the $m = 48$ ({\\ce{O2}}) ps}.\n\n"
+ "\\rem{lp}{ more text {\\ce{O2}} further text {\\ce{H2O}} . some other text the $m = 48$ ({\\ce{O2}}) ps \n"
+ "where more text {\\ce{O2}} further text {\\ce{H2O}} . some other text the $m = 48$ ({\\ce{O2}}) ps from \n"
+ "who more text {\\ce{O2}} further text {\\ce{H2O}} . some other text the $m = 48$ ({\\ce{O2}}) ps.}\n\n"
+ "\\rem{lp}{ more text {\\ce{O2}} further text {\\ce{H2O}} . some other text the $m = 48$ ({\\ce{O2}}) ps. \n"
+ " more text {\\ce{O2}} further text {\\ce{H2O}} . some other text the $m = 48$ ({\\ce{O2}}) ps.}\n\n"
+ "\\subsection{other}\n"
+ "Our bla bla bla";
final String subst = "$1\\\\textcolor{red}{\\\\underline{<<ReTe>>}}$4";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}