# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"([^\s]*\s*)\\rem\{(?:lp|db)\}(\{((?>[^{}]|\n|(?2))*)\})(\s?[^\s]*)"
test_str = ("\n"
"Some text etc word\\rem{lp}{ more text {\\ce{O2}} further text {\\ce{H2O}} . some other text the $m = 48$ ({\\ce{O2}}) ps}.\n\n"
"\\rem{lp}{ more text {\\ce{O2}} further text {\\ce{H2O}} . some other text the $m = 48$ ({\\ce{O2}}) ps \n"
"where more text {\\ce{O2}} further text {\\ce{H2O}} . some other text the $m = 48$ ({\\ce{O2}}) ps from \n"
"who more text {\\ce{O2}} further text {\\ce{H2O}} . some other text the $m = 48$ ({\\ce{O2}}) ps.}\n\n"
"\\rem{lp}{ more text {\\ce{O2}} further text {\\ce{H2O}} . some other text the $m = 48$ ({\\ce{O2}}) ps. \n"
" more text {\\ce{O2}} further text {\\ce{H2O}} . some other text the $m = 48$ ({\\ce{O2}}) ps.}\n\n"
"\\subsection{other}\n"
"Our bla bla bla")
subst = "$1\\\\textcolor{red}{\\\\underline{<<ReTe>>}}$4"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.