const regex = /([^\s]*\s*)\\rem\{(?:lp|db)\}(\{((?>[^{}]|\n|(?2))*)\})(\s?[^\s]*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([^\\s]*\\s*)\\\\rem\\{(?:lp|db)\\}(\\{((?>[^{}]|\\n|(?2))*)\\})(\\s?[^\\s]*)', 'gm')
const str = `
Some text etc word\\rem{lp}{ more text {\\ce{O2}} further text {\\ce{H2O}} . some other text the \$m = 48\$ ({\\ce{O2}}) ps}.
\\rem{lp}{ more text {\\ce{O2}} further text {\\ce{H2O}} . some other text the \$m = 48\$ ({\\ce{O2}}) ps
where more text {\\ce{O2}} further text {\\ce{H2O}} . some other text the \$m = 48\$ ({\\ce{O2}}) ps from
who more text {\\ce{O2}} further text {\\ce{H2O}} . some other text the \$m = 48\$ ({\\ce{O2}}) ps.}
\\rem{lp}{ more text {\\ce{O2}} further text {\\ce{H2O}} . some other text the \$m = 48\$ ({\\ce{O2}}) ps.
more text {\\ce{O2}} further text {\\ce{H2O}} . some other text the \$m = 48\$ ({\\ce{O2}}) ps.}
\\subsection{other}
Our bla bla bla`;
const subst = `$1\\textcolor{red}{\\underline{<<ReTe>>}}$4`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);