using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:\d{2}-\d{2}(?:;|$))+$";
string input = @"10-02;34-05;12-12;23-05;10-42;44-05";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}