package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(?:\d{2}-\d{2}(?:;|$))+$`)
var str = `10-02;34-05;12-12;23-05;10-42;44-05`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}